Two Video, one blue and long annotation chrash problem

I use two videos in a dialogue for annotation.
Since Elan 6.x. the second video is always blue. I have to jump back approx a second and play it, repeat it twice, only then can I see the video. The problem only occurs on Windows (I have version 10). Previously I and my (Win10) colleagues on ELAN 5.x. didn’t have this problem.

The second thing is that long annotations (for example translation) that go beyond the current window sometimes leads to crashes. With Win10, a message “Child process exited with code 1” (ELAN.exe) appears after the forced termination. On the Mac (OS Monterey 12.6.x) - have same problem - but shows no message.

Can this be solved or is this a bug?

Considering the first problem: we have several reports on a video not shown but the blue panel instead. In some cases no video is shown at all and in some cases only the first video is missing. In most cases, I believe, the problem was irreparable; once the blue panel was visible there was no way to get the video to display. It seems like that is different in your (and your colleagues’) case. So far we haven’t found a clear cause for this problem, nor a solution. We’ve been trying to get as much information as possible from the logs etc. but so far have no clue what we can do to improve this. It seems that often the problem is that the aspect ratio of the video (and width and height) could not be detected, unclear why.
Sometimes after opening a file the video area has to be resized a bit in order to make it visible and size correctly, but that doesn’t seem to be the same problem as yours. I’m thinking what could be the difference between 5.x and 6.x where it comes to the media player, it doesn’t immediately ring a bell.

I’m not sure if I fully understand the second scenario: I’m not sure how the length of the annotation plays a role. If an annotation goes beyond the current window, I would think that playing that segment comes down to the same as starting the player somewhere and just let it play; every time the crosshair moves beyond the end boundary of the window a new segment or window is loaded. If you do that, does that also (sometimes) lead to a crash in your machines (win and mac)?


Thanks for your answer.

I was a little vague on the first one: if I load eaf and press play directly, the first video (left) plays at the point where the red control line is in the annotation window. The second video (right) also plays, but from the beginning (i.e. fully asynchronous). Then I do these actions described above, then they are in sync.
I can also confirm that the wrong size is the issue, that happens sometimes too. But this is not consistent. Sometimes is simply to close Elan and reload the file, then the video sizes are correct again. Or if I open the file again another day, it’s fine again.
All for your information.
It is also possible that the media player has an influence and because it is also being updated: perhaps something new has been added that is not entirely compatible with the ELAN?

Second: I can’t explain it better than this: The annotations/glossaries that are within the window area, i.e. properly zoomed, are not a problem. However, if there is an annotation in a line where the start is outside (i.e. before the time in the visible area) and the end is also outside (i.e. after the time in the visible area) and - important - it is active (i.e. marked in blue), the ELAN program goes to waste.
Her is not to play the video a problem, it’s if the long annotation become active i.e. if i move from a short annotation to the long annotation from a tier to next tier with ALT+ arrows, because ELAN suddenly hangs up.



The two issues of the first point are known and can be observed on different operating systems but not always reliably and consistently. E.g. we have two almost identical macOS laptops and on one the video almost always doesn’t fill the entire designated rectangle after opening a file (some resizing is required to force it to fill the panel), while on the other this behaviour rarely occurs.
I believe both issues are mainly ‘threading issues’. The actual player is always a component of the host platform, not an ‘own’ ELAN component and although ELAN tries to set the media time and the size of each video after ‘full initialization’, it can still be that the lower level player is not ready yet at the moment of these calls.

The second point sounds like this is something we should be able to reproduce if it is indeed caused by a bug. Some first testing on Windows didn’t cause a crash but we’ll have to test a bit more and on other platforms too. What happens in such a case (e.g. ALT+Arrow activation of an annotation) is that the player jumps to the begin time of the annotation and that the timeline view updates to show the begin of the annotation (with a small margin to the left). I think almost the same sequence happens in other situations, e.g. when clicking an annotation (which is out of the view) in the grid viewer.
We’ll have to test more to see if there is indeed a bug (which doesn’t occur in all cases).

Update to problem#1:
I found the solution: Uncheck the box at Edit → Edit Preferences → Platform/OS → Java Direct Show Framework → “Java -Microsoft Media Foundation …”
Now the videos work (no asynchronicity), they show the same place as the red thread in the annotation window. (This is on PC/Win10)

However, with the “Lexicon Services” I have problems with showing preview videos when I want select glosses from the eCV.
Therefore I have the following setting: Change Edit → Edit Prefercens → Platform/OS → to “VLC Player Library”
By this solution the preview video at eCV now works on PC/Win10 as well as MAC/Monterey. Previously, displaying the video in PC was inconsistent (incorrect video size) and in MAC only dark green image was shown.
The same solution that the synchronicity of both videos as described above works now on PC/Win10.

@Han, maybe the information is relevant for you.

Thanks Nik, it’s always useful to hear about the problems users are facing but also about the approaches that do work. So, if using the VLC player works best in your cross platform situation that is fine.
In general it is my impression that the VLC player is less accurate when it comes to frame precision, compared to the default native player frameworks, but whatever works best is fine.

So far I’ve assumed that the media files are .mp4 but maybe that is not the case? I just wanted to mention that deselecting the “Java - Microsoft Media Foundation” checkbox (instead of selecting a different framework than Direct Show) only makes sense if there is a DirectShow codec for mp4 files installed. In most cases selecting a different framework, like in your case VLC, is the better approach, I think.