Trouble adding new session

I’m trying to add sessions to my local corpus, but only occasionally do they actually appear, once I’ve added them. I’ve tried to add them in two ways: one is by dragging a session from my favourites, however while it appears to be dragable, (ie. it doesn’t bounce back to where it came from), it doesn’t appear in the local corpus. The other way I’ve tried is I right click on my ‘Dalabon Corpus’ node, and choose ‘add session’. A ‘new session in Dalabon corpus’ window appears, which I can edit, but it doesn’t appear in the local corpus. Saving it doesn’t make it appear either, so once I close this window the information appears to be lost.

Can you suggest what I might be doing wrong?

If you are using the webstart version and you have seen a certificate warning and clicked disallow, then this could be the cause because the application would not be able to write (save) anything to disk.Â
Is it only an issue with sessions, or does this happen with corpus nodes also?
Meanwhile, I will add a self test into the application so that you are warned if the working directory is not writeable. If this is not the issue then we will need to look in to this further.
Peter Withers

Hi Peter,

Thankyou for your reply. I’ve installed the application (the stable version) - I’m not using webstart. I’m unable to create new sessions or corpus nodes, and I’m unable to drag sessions from the favourites - they only appear as windows titled ‘new node in Dalabon Corpus’/‘new session in Dalabon corpus’, but not on the left hand side of the screen in the actual local corpus.

Further to this, I just had a hunch that my sessions weren’t actually in my corpus node (there was no arrow next to the node), and thinking this might be the problem I dragged them all into the corpus node. Only one appeared. The other 8 or so sessions were lost. I closed the programme without saving, and opened it again, thinking it would revert to how it was at the previous save, but it seemed to have saved automatically, and only 1 session was there as before I closed it. Have I lost all my work?

When you add features to the application (like a self test application that lets us know if our working directory is unwriteable), I presume you are adding them to the testing version yes? (The version I am having these issues with is Arbil Stable. Would you recommend us to use Arbil at all at this stage for our project or would it be better to use IMDI?


Any new features are only added to the testing version until they have been adequately tested. As a result, the self test on start up that I mentioned will only be done by the testing version at this stage.
Could you email me the arbil error log of the version that you are using, this can be found under the help menu. Just copy and paste the entire text into an email.
It is unlikely that any sessions you created would have been lost. Most likely they will still be on disk just not shown in the local corpus tree.
Normally I would recommend that you use the stable version, but in this case I think it would be useful to run the testing version once to see if it resolves any of the issues. It would also be useful to see any error log that the testing version produces. I am very keen to track down the cause of this issue and look forward to seeing any error logs.

Thanks Peter. I will email you the error log, and download and try the testing version in the meantime.