"The external CV is loaded from cache" error when opening EAFs


Some years ago, we set up an ECV for our corpus, and were successfully accessing it from ELAN when opening EAF files.

However, now, we get this message whenever we open an EAF:

The external CV is loaded from cache

This has been happening for a while, on various machines & software versions (Windows 10 with ELAN 5.5; Mac OS 12.6.2 Monterey with ELAN 6.4).

The EAFs in question have the ECV near the bottom:
<EXTERNAL_REF EXT_REF_ID=“er1” TYPE=“ecv” VALUE=“http://bslecv.ucl.ac.uk/static/ecv/bslc.ecv”/>

The ECV is still present in this location and it has not changed for a long time.

This is not a problem on computers which have already cached an ECV, but it is where ELAN does not find a cached file because in this case, no CVs are present.

I would be grateful for any help with this - thank you!


Hello Heidi,

If I try to link the ECV in a new transcription using the URL you mention, it indeed fails with a (slightly mysterious) error message in the log (View->View Log…).
But if I try to link the ECV with this URL:


it works. So, with https instead of http. Could it be that the server software has been updated in the meantime?
If you can reproduce this solution on the various machines your group is using, it would be best to update the link in the EAF files (I don’t think ELAN has a convenient function for that).


Thanks for your speedy reply Han!

Your suggestion worked for me (Mac) but not for my colleague (Windows) - he reports:

For http:// I get this:

Jan 12, 2023 4:11:51 PM mpi.eudico.server.corpora.clomimpl.dobes.ECVStore loadExternalCVS
SEVERE: Parse failed http://bslecv.ucl.ac.uk/static/ecv/bslc.ecv

For https:// I get this:

IO error: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Jan 12, 2023 4:19:04 PM mpi.eudico.server.corpora.clomimpl.dobes.ECVStore loadExternalCVS
SEVERE: Parse failed https://bslecv.ucl.ac.uk/static/ecv/bslc.ecv

We are going to follow up with our web server maintenance team to see whether they have changed something that has caused this issue - it would be a lot simpler if something could be changed once on the server rather than in each of our hundreds of EAFs.

Actually I think that for me, the problem is resolved at least in the short term, because now that I have successfully loaded the ECV by editing one EAF to use https, it seems to have been cached so that when I open other EAFs (still http:), although I get the “loaded from cache” message again, now it has a cache to use, and it pulls up the necessary CVs. This will only work until we want to change the ECV of course, but that is not expected in the short term.

(Incidentally, I can’t view my logs: when I do View → View log, I get “Cannot access the log file. There is no log handler”. This happens for EAFs with http: or https: paths for their ECVs.)

best wishes,

Hello Heidi,

Strange, I did my https testing on a Windows machine and didn’t see the ValidatorException error. Is that also ELAN 6.4?

If, for the time being, working from local cache is acceptable, then you indeed don’t need to update all EAF’s yet. If all else fails, I guess it should be possible to copy the cached version of the ECV from e.g. your Mac to other machines that are not able to connect successfully once.
ECV’s are stored inside a folder named “CVCACHE” inside ELAN’s data folder. You’ll have to copy the folder (with subfolder etc.) named bslecv.ucl.ac.uk

There is an error in a configuration file in one of the macOS distributions that causes the failure to log anything. I’ll folllow up on this in the next post (from a different machine).


Concerning the logging problem:

If you right-click the ELAN_6.4(.app) folder in the Finder and choose “Show Package Contents”, then go to Contents/app, you’ll find a file ELAN.cfg which can be opened in TextEditor.
The line


should be changed to


After saving the file and relaunching ELAN, the logging should work again.

Sorry for the inconvenience!

Hi Han

Thanks for your responses. I am checking with my colleague about his version of ELAN on Windows.

And that’s a useful suggestion about just copying the cached ECV between Macs as required - we may do that in the short term.

Finally, your fix for the mac logging problem has worked - a great end to the working week!


Hi Han

Just to close the loop on the Windows part of this: my colleague has confirmed that https DID work using ELAN 6.4. So all good.

Best wishes

Thanks for this update, Heidi, good that this mystery is solved!