Exporting conversations: speakers turns

I have a problem when it comes to exporting the text file of a conversation between two speakers with many overlappings: the order of the interventions of each speaker is not correct, i.e. speaker A appears after speaker B, when the first one saying sth. is A. Also, there are some overlappings that are visible in the txt-file and others that just appear in the following block. I suspect it could be related to the way of segmenting, but I’m not sure, since I tested different things and it’s still exporting it in this messy way. Is it maybe related to some configuration (export in block etc.)?
Thank you in advance!

It is difficult to say whether there is a bug in the export or if there is a reason for the order in which text occurs. Is this about the export as Interlinear text (i.e. which function was used for the export)?

Maybe you can send an example .eaf, the exported .txt file and a screen capture of the export settings to me (han.sloetjes AT mpi.nl) so that I can have a look? We can then see what would be useful to post here to illustrate the problem. Or if you prefer, you could maybe upload some explanatory screen captures here?


After exchange of some files, including screenshots of export settings, it appeared that the problem is caused by a combination of settings in the Interlinear export window together with a mismatch of the preview in ELAN and the result in a text editor.

The annotations are always exported in chronological order., but the Wrap Blocks setting co-determines the horizontal and vertical position of annotations. If this setting is not set to “Each Block”, multiple annotations of multiple speakers can end up in a single block of lines, in which case the order of the tiers in the right-top table is leading.
In the ELAN preview screenshot below, the first line contains an annotation which is actually the second annotation in the transcription. It is shifted to the right, to place it behind the first annotation which starts on the fourth line (because of the timestamps and silence duration lines).
But when this setting is combined with the option Tabs Instead of Spaces the result as visible in a text editor looks quite different (second screenshot of a text editor): the shift to the right on the first line looks almost gone and it looks like the order of tiers/annotations is wrong.

The two Tabs related options in the export window more or less assume that the final formatting of the output is handled elsewhere e.g. for a publication. The default formatting in the preview window depends on the use of a fixed-width font in combination with padding with spaces; if in a publication different fonts are used the alignment has to be corrected later.

The following two screenshots illustrate the issue.

Example in TextPad2

Overlapping annotations are difficult to visualize with this export option, for that, one can have a look at Export As Time-aligned Interlinear Text...