Error message Recognizer failed


This week I’ve been having trouble with recognizers I’ve used successfully before. Both the fine segmentation recognizer and the speech/nonspeech recognizer (and the pipeline too) have been spitting out the same message: “An error occurred inside the recognizer: Recognizer failed.” The silence recognizer on the other hand is working without a problem.

I get the same error on both Windows and Mac, on different ELAN versions, with different files, with files on a shared network and on the computer’s drive.

Do you happen to have any suggestions how I can fix this? Thanks a lot!

It could be the server on which those recognizers are running needs to be restarted (although the error message is unclear). We will check that tomorrow.

It appears there were indeed some server configuration issues, which have now been solved. The recognizers should return results again.
Apologies for the inconvenience!

Thanks, that was very quick!! :slight_smile:

Hello again, I seem to be having a similar issue but with only one of the recognizers: the diarization tool. Every other recognizer works well, but this one produces the same message as the one from before: “An error occurred inside the recognizer: Recognizer failed.”
Could it be the same reason or is it a problem on my end?

I tried the two recognizers with diarize in their name (Speaker analysis component to diarize etc. and Speaker diarization pipeline etc.) and both seem to work.
Any other relevant information in the output shown when you click the Report button after the failure?