Ergonomic issues: back to the beginning, sound playing in Linux, annotation selection

I’m listing three ergonomic issues that are a bit annoying when working with ELAN.

  1. When starting to work with an already annotated file, one has to read a bit of the file before being really able to navigate through the annotations without being sent back to the beginning of the file. I’ve discussed with other ELAN issues having the same issue, and I don’t think it is platform related.
    I think this issue might be related to a variable no properly assigned in the code.
  2. On Linux, when playing audio files (using VLC library), the sound is often “hacked”/stuttering. This is really annoying, in particular when playing short audio segments (less than 5 secondes).
  3. When editing annotations, it is sometimes not possible to select the portion of audio file from the spectrogram that we want to annotate (even though it should be possible). To reinitialize the possibility of selection, one has to reselect the annotation unit and then one can select the segment they want to annotate.

Hello, thank you for the feedback. I’ll add some preliminary comments on the three issues you mention.

  1. I’m not sure if I fully understand this situation, how to reproduce this. At first I thought this was about returning to the point where one left off at the end of the previous annotation session (“restore previous session?”, which seems to work), but probably it is not that? If I open a file I seem to be able to jump to any position in the file, without the player or the view jumping back to the beginning. More details would be welcome.

  2. Audio files, is that .wav or a different format? On my Linux system audio segments playback doesn’t seem to be too bad, with .wav. In general, the embedded VLC player/library in ELAN is not the best in terms of precision or accuracy etc. On Linux there is only the JavaFX based player as an alternative for a few formats and the JavaSound player for .wav.

  3. I assume this is about the situation where a time-alignable dependent tier is active and/or an annotation on a time-alignable dependent tier is active (selected)? The time selection is then limited to be within a parent annotation’s time interval. If it is indeed about this situation; this has been implemented this way with the intention to help the user, by showing where an annotation on the dependent tier can be created while she or he is dragging a selection. But maybe it is not about this particular situation?


Regarding issue 1. Sorry, my explanation was not so clear, but the problem is systematic and, I’ve discussed it with other users who are annoyed by it as well, so I’ll try to explain it better. When one opens an Elan file, and navigates through the annotations without having played once the audio, if they selects an annotation and plays it, it will return to the beginning of the file. I’ve tested this on multiple ELAN files, and it seems that maybe, the issue only with files possessing multiple “none” type tiers. Should I send a file?

Regarding issue 2. I’ll try to narrow a bit more the issue. Unfortunately, at the moment, the files I have at hand do not seem to have the issue. I’m in general working with .wav files, so the problem shouldn’t come from the format (unless it is related to the sampling options).

Finally, regarding issue n°3, no, no, it’s not that. I’ll try to record the situation next time I face it, but I’ve seen the bug happening as well on one of my colleague’s computer (using Windows, so it’s platform independent). What happens is that sometimes, the selection within the time span of a unit, in the context of a “included in” type tier, is not possible and the whole “hyper” unit has to be reselected before to being able to select the segment of file that one wants to annotate. It is one of those bugs which is appearing a bit randomly, and which is annoying only when annotating a lot of segments.

With the additional information and trying with .wav only (no video), I’m now able to reproduce the problem of the crosshair and the timeline being ‘stuck’ at the start of the file if the player didn’t play yet. It is a VLC specific problem and does not occur with video. I’ll have to check the code, maybe the player is initialized differently in case of a .wav file. When I open a file with video I always hear a short, 1 second playback of the sound which I don’t hear in the .wav only scenario. I believe that playback of a short fragment while the file is still opening, is a kind of workaround solution to get the player properly set up.

I’ll see if I can reproduce point 3 with included in, I didn’t get to that yet. In case you want to send anything later, you can direct it to han.sloetjes AT