Elan Template file won't save? Also keyboard shortcut no longer works?

Hey Han,

For the Elan annotation deletion I usually used “option + d” on the previous versions of Elan on my macbook but the Elan 6.7 doesn’t work. I tried to find an alternative but couldn’t find it in the manual for why option+ d doesnt work. I know the manual said alt + d but I’m assuming thats for windows.

Also, when I tried to make a template file, it would say "unable to save the template file: /… .etf (Read-only file system))

Thank you so much for your help! Much appreciated :slight_smile:

Hi Ingyun,

Most keyboard shortcuts with only the Alt or Option modifier key have been changed. The default shortcut for deleting an annotation is now Option+Cmd+D on the Mac (it is shown on the right side in the Annotation menu).

On my M1 mac with macOS 13.1, that combination, Option+Cmd+D is defined on the System level to Hide or Show the Dock. Shortcuts defined on the System level take precedence over the ones defined in ELAN. There are two possible solutions:

  1. disable the system level shortcut via System Settings, the Keyboard category (in the left side panel), then the Keyboard Shortcuts... button in the right side panel, then the Launchpad & Dock category on the left side and the checkbox Turn Dock hiding on/off on the right side.

  2. change the shortcut for deleting an annotation in ELAN, via Edit->Preferences->Edit Shortcuts...

Concerning the template file, it looks like you are trying to save the file in a location where you don’t have don’t have permission to save a file (or where ELAN doesn’t have permission to save a file). Could that be the case? Can you save an .etf file somewhere in your Home folder (or sub-folder), just to check if this assumption is correct?