Elan freezes while working on it

We have been utilizing Elan for the past year. While this software has proven valuable for our annotation tasks, it has also exhibited some issues. Specifically, we have experienced frequent freezing and occasional loss of saved annotations. However, our current concern revolves around a new challenge when working with videos captured on mobile phones. Regrettably, Elan does not function as expected in these scenarios.

When attempting media synchronization or initiating annotation on mobile phone-shot videos within Elan, the application freezes abruptly. Interestingly, this issue does not appear when working with videos shot on Apple tablets, as Elan performs adequately in such cases.

To provide more context, here are the details of the videos we encountered issues with:

Annotated Video:

  • Length: 00:20:46
  • Frame Width: 720
  • Frame Height: 1280
  • Data Rate: 3001kbps
  • Total Bitrate: 3319kbps
  • Frame Rate: 60.00 frames/second
  • Audio Bit Rate: 317kbps
  • Channel: 2 (stereo)
  • Audio Sample Rate: 48.000kHz

Videos that Cannot Be Annotated:

  • Length: 00:00:17
  • Frame Width: 906
  • Frame Height: 1920
  • Data Rate: 3022kbps
  • Total Bitrate: 3346kbps
  • Frame Rate: 29.97 frames/second
  • Audio Bit Rate: 324kbps
  • Channel: 2 (stereo)
  • Audio Sample Rate: 48.000kHz

We would greatly appreciate any assistance or insights regarding the reasons behind our inability to annotate the videos. Your expertise on this matter would be invaluable in resolving the issue.

Thank you for your attention and support.

Thank you for the detailed information and problem description.

Concerning the videos: based on the listed properties it isn’t really possible to predict which one will play and which one won’t. The encoding or codec of the video probably has a higher predictive value, although even then it might not always be possible to tell if a video will work or not. (More information about a media file can be extracted with e.g. MediaInfo, but maybe you already used something like that.)

It is important to keep in mind that ELAN delegates media playback to one of the player frameworks available on the system. If the framework produces a clear error message when it is given a certain media file, something like ‘unsupported format’, ELAN can show that to the user. If not and the player ‘accepts’ the file, it is difficult for ELAN to check or detect proper playback. The media framework might produce messages that end up in ELAN’s log (View->View Log...), but we know that in many cases when lagging or bumpy playback occurs, no traces of that can be found in the log.

We have some reports of users who had problems with recording produced by mobile devices and whose problems were gone after conversion or re-encoding based e.g. on the guidelines in this guide. Even when it is e.g. a conversion from .mp4 to .mp4.
Obviously it would be good to know exactly what in the encoding causes problems; it might be possible to take that into account in the settings before the recording.

Concerning freezing of ELAN: we’re at the moment looking into freezing related to manual scrolling (in the timeline viewer, especially with a trackpad) while the player is playing.


Hi Han and everybody else on the ELAN developer team,

As I am having trouble with what you mention in the last paragraph of your answer (ELAN freezing related to manual scrolling while playing media), I was wondering whether you have already found any way to fix this, or any workarounds? Do you have information on whether this concerns all modes or only (as is mostly the case when I come across this bug) Annotation mode?

I am using ELAN 6.6-M1 on MacBookAir M2, 2022 with macOS Ventura 13.4.1. Do you think that downgrading my ELAN version or using the ELAN 6.6 version with Java 20 runtime environment be of any use? Or should I just try to avoid scrolling/typing annotations while playing data in Annotation mode?

Thank you for your answer!

Hi Elisabeth,

Sorry for the delayed response, could not write here because the forum was down since yesterday.

Primarily the freeze issue (with the manual scrolling while playing media) which was identified in ELAN 6.5 has been given a fix in ELAN 6.6.
We have fixed the deadlocks that used to occur in the above described scenario.
I tried the ELAN 6.6-M1 as well as ELAN 6.6 on my M1 machine. I can scroll with trackpad while playing media without any issues. maybe the issue still persists with m2.

You could try using ELAN 6.6 (non m1 version) and let us know if you can do the scrolling along with playing media steadily ?

Please note that when you download ELAN6.6 after installing it shows ELAN6.6-M1 ( just a typographical error). To make sure that it is ELAN6.6 you can view the log from View - View log and there the OS arch should be : x86_64.

Best Regards

1 Like

Hi Divya,

No worries, I saw that the forum was down and that you had no chance to reply earlier. Thank you for what I consider a very fast reply anyway :slight_smile:

Oookay, I may have unduly jumped to the conclusion that the error I am experiencing is a version of the scrolling-while-playing because it seemed similar enough, event though it is not literally that, and I should have stated that in my first message:
Actually, I encountered the freezing problem in ELAN (6.6-M1) when I type text in an annotation or select it to do so while the player is running, and if selecting an annotation that is longer than what fits in one scrollview. I verified that just now to make sure I give reliable information this time, and was able to intentionally replicate the problem in both the M1 and non-M1 version (double checked the OS arch for both, as you told me to).

Maybe a bit of context is helpful, too? I use ELAN mostly to get an overview over my data (.mp4 files between 45 and 55 mins), first highlighting the phenomenon I am interested in by creating rather long annotations in segmentation mode and then adding descriptions in annotation mode. I suspect that this is a way of using ELAN that does not really fit its programming core strengths, as it can deal much better and is much more powerful with short clips and short annotations? But while I have other tools for the finetuning that work better with my workflow and transcription requirements, ELAN just really neatly fills the tool/method gap I have when it comes to exploratory sightings. I would be very happy to be able to keep using it for this.

Sorry again for the inaccurate problem description. I hope you can work with my updated problem report?


Dear Elisabeth,

No worries at all. :slight_smile:
Thank you very much for the detailed description and reproduction steps.
very clear about the issue now.
I think long annotations should not cause the problem technically. I tried the exact scenarios in my machine , however I am able to perform fine in those scenarios. I am unable to upload the screenshot video I took of the scenarios in the forum.
Just few more questions to see what could be the difference.
What is the Media Framework selected ?
In case of a long annotation, how long does the annotation length span ?
Do you have any colleagues with M1 or Mac intel machines to test the same scenarios? ( to see if it is indeed OS issue- m2 )

Best Regards

Hi Divya,

Thank your for going on this bugsquashing hunt (or wild goose chase?) with me :slight_smile:

I did not intentionally select a Media Framework and just used what was selected as default, which was Java – AV Foundation Framework.
Concerning the length of annotations: Short ones can be under 1 sec, but have never caused trouble. The really long ones can be up to 3 min and seem to cause trouble whenever the viewer needs to jump back to its start (when the red player line is in the middle or at the end of the annotation and I double click in Annotation mode to add text).
I tested the scenario described above with my colleague who uses a M2 Macbook as well, and we were not able to recreate the problem. We used different video data (because I am not allowed to pass my data to a different device…) of similar length and created an annotation of similar length in Segmentation mode before entering text in Annotation mode.

As neither we nor you were able to trigger the problem, this may have to do more with my machine and/or data than with ELAN? *sigh*

Thank you and best regards,

Hi Elisabeth,

Very mysterious bug :slight_smile:
We can look into the log files to see if there are any useful errors logged , related to the freeze.

If possible, once the freeze happens , can you share the log files elan0.log (elan1.log etc. all of them) to ( Divya.Kanekal AT mpi.nl ) ? Located in ELAN’s data folder.

Best Regards