ELAN crashes with special characters in Transcription mode

I’m a new user to ELAN. I am experiencing a problem with two special characters when I enter Transcription mode: č, and ę. These two characters freeze ELAN when I use them. I’ve searched in the font browser as to which fonts can use these characters, and I changed my font to one of the options. There obviously is something that I am missing. I am currently using a macOS ventura 13.4.1 if this helps. Any help or feedback would be appreciated.
edit I should state that I am using a 3rd party keyboard when using these characters

1 Like


This problem looks very similar to the one described in this post. The information from the log file we received in that case, points to some low-level error. We haven’t been able to reproduce it ourselves. It is still unclear whether it is more likely to occur on an M2; maybe you can add whether your Mac is an M1 or M2 (or maybe neither of these)?

Just to be sure, did changing the font make any difference? If not, then maybe downloading ELAN 6.4 is the best option, until we have fixed this problem (hopefully) in the next release?


Hi Han!

I have started having the same issue suddenly.

It is occuring with ELAN 6.5 on my Mac M1. I switched to back Elan 6.4 M1 and the issue seems to have gone away for the most part (though it occured once and I am not sure why).

Should I send you logs for 6.5?

Hi Coleman,

Yes, you’re welcome to send logs so that we can verify whether this is indeed the same issue with the same cause (it probably is). I guess we can overcome this problem, in our code, by ‘catching’ the error when it occurs and ‘dealing’ with it by doing nothing (i.e. by not re-calculating the required height of the cell in that case). But it is difficult to test if that error does not occur on our machines.

1 Like

I just emailed you a recent log of it crashing with 6.5.

Hi Han,

It seems that I am having something similar to this issue. As I edit the file in Transcription mode, ELAN 6.5 freezes abruptly, after which it has to be forcefully stopped. This happens after I select some text segment in a cell and start typing something over it. I’m not sure if the cells that cause this behavior have anything in common. On the one hand, there seem to be cells that trigger this consistently (I’m not sure if this is a coincidence, but some of them contain a combination with a combining diacritic, i̮, which is otherwise rare in my data). On the other hand, some other cells (including ASCII-only ones) cause the freeze only once at random, but work normally when I reload ELAN. I tried downgrading to 6.4, but the problem seems to have been present there already (although I got the feeling that it did not occur so often there as in 6.5).

Unlike in the other reported cases, I am working on a Windows machine.

I can send you the files that contain cells where I can reliably reproduce this behavior on my computer.

Best regards and thanks for your work,

Hello Timofey,

The issue of Elan freezing in Transcription mode especially when using diacritics is addressed and the fix is now part of ELAN 6.6. Last week ELAN 6.6 is released. ELAN 6.6. You can try the release and let us know if you can edit cells in transcription mode more steadily.

Best Regards

Hello Divya,

I’m sorry, I remembered the version number incorrectly: I actually meant 6.6 and 6.5, rather than 6.5 and 6.4. So what I meant is that the issue is still there in 6.6. Interestingly, everything works fine once I remove all "i̮"s from the file.

Hello Timofey,

No worries at all. When we edit the cells in transcription mode with a combining diacritic ( in 6.6) , we cannot reproduce the issue. The issue might be a combination of diacritic and some more parameters.

Indeed it would be helpful if you could share the files that contain these cells for us to reproduce it and and check where the issue is originating from. Could you also attach the log files. There might be information about the crash in the log. You can share the files to ( divya.kanekal AT mpi.nl )
The log files are named elan0.log etc. and can be found in the ELAN data folder .

Best Regards

Dear Timofey,

Thank you for the files and the detailed reproduction steps.
When I followed the exact steps which you mentioned yesterday with many attempts I was able to replace the cell text with the new characters and words. ( I was typing few characters , words with gaps ). I tested this on 6.6 Mac m1.
However this morning i tried again by typing a little long text (characters with no gaps) then I could reproduce the issue. ELAN froze.
We will look into the root cause of the issue.
Maybe downloading ELAN 6.4 is the best option for now for the transcription mode cell edits ?

Best Regards