ELAN 6.3 works slow and keeps hanging

I started using the new version of ELAN last week on my MacBook Pro, but it keeps hanging and works very slow. So I turned back to using 6.2 as that still works better for me. I only work with audio data. I’m not sure what the reason could be, but I thought to mention it, perhaps other users are experiencing the same issue.

Thanks for reporting this, it’s useful to know.
There are at least a few similar reports and for us it would be good to understand what could be the problem. In principle, when the Spectrogram viewer is not used (removed from the window via View->Viewer), our expectation would be that version 6.3 should behave similar to 6.2. The main difference then is that 6.3 has Java 17 included and 6.2 has Java 14 (with the exception of the macOS M1/aarch64 versions, they both have Java 17 included). Especially on Windows we have a slight suspicion that hard crashes there might be related to the Java version (see e.g. this thread).
In case you have any of those hs_err_pid nnn .log files on your system (not sure if on macOS they are in the same location as on Windows), we would be interested in receiving them.

-Han

Dear Han

Thank you for your reply! I am coming back to this quite belated, for which I apologise. I have just downloaded ELAN 6.4 and the same problem occurred, but I did like you suggested and disabled the Spectrogram viewer. It now seems to be running like 6.2 indeed. I will let you know should any more issues come up!

  • Aaricia

Dear Aaricia,

Thank you for this information, that is very useful, disappointing as it is.
May I ask what type of audio files you use, are these .wav files or some other format? This can help us in our search for the cause of these problems.
Anyone’s log files ( hs_err_pid nnn .log and elann .log) after crashes are still welcome (han.sloetjes AT mpi.nl).

-Han

Dear Han

I am indeed working with .wav audio files (as in the previous versions of ELAN other audio file formats did not show up in the wave audio viewer). I’m not sure if I can access log files since ELAN didn’t actually crash?

Best wishes
Aaricia

Dear Aaricia, in that case (.wav and no crash) there’s no need to look for the log file(s) and send it to us! (But maybe other users reading this thread and running into ELAN crashes are willing to share log files.)

Thanks!

Dear Han

My student and I have been working with ELAN 6.4 this week and have had several times that the program continues playing the audio while the program is not functional, none of the buttons work and we can’t even close the .eaf file. I have had several times that I had to do a ‘forced stop’ on my Mac and my student had to do something similar on her Windows 10 computer. I’m not sure if there is anything we can do to resolve this issue?

Best wishes
Aaricia

Dear Aaricia,

Thanks for reporting this. I’m afraid I have no solution at hand. Maybe it is possible to add some more information? Are you both using the default media player framework of your platform? In which “working mode” (Annotation mode, Segmentation mode etc.) is this? Can the error be linked to a specific action (so that we can try to reproduce the problem)?

Best,
Han