ELAN 6.3: Child process exited with code 1

Hi all,

I’ve encountered a problem when launching ELAN 6.3 on my Windows 10 PC. Everytime I try to launch it, a window containing the message “Child process exited with code 1” pops up. The weird thing is that it works fine on my laptop, where I’ve done most of my annotating so far. I want to switch to my PC and work there, but it just doesn’t work since I can’t start the program. I also tried to launch v6.2 and 6.1, but when I start those nothing happens at all, and not even an error message appears. It’s very strange. I hope there is a solution to my problem, and I will provide some more info (e.g. my PC’s specs) if necessary.

Thanks- Jacob

Hi,

I’m not familiar with this error. Maybe the system’s Event Viewer contains more detailed information after a failed launch of 6.3?
A quick internet search for that “exited with code 1” message indicates that this message is often linked to the Command Prompt (cmd.exe), sometimes in relation with the installation of another application. Maybe that is something to look into: specific applications that are installed on the PC and not on the laptop (this may not be feasible)?

-Han

I’m not familiar with how Event Viewer works, but launching 6.3 doesn’t seem to add a new error, warning, or information to the overview panel.
Something I forgot to mention earlier: When I first installed 6.3, 6.2 hadn’t been uninstalled yet, maybe that’s where the cause of the error lies. I’m really not sure about conflicting programs, considering that I’ve used 6.2 on this PC before, and I haven’t installed any other programs since then.

I’m not sure, but I would expect such error under Windows Logs in the left pane and then in the Application or System log.

ELAN 6.3 and 6.2 (and other versions) can be installed on a system simultaneously, that shouldn’t lead to any errors (assuming they have not been installed in exactly the same folder!).

Unfortunately, nothing shows up in those logs.
When I uninstalled 6.2 I actually checked, and there were indeed two folders, one for 6.3 and one for 6.2.
I really hope there’s some solution to this problem, but if there is not, I can just continue working on it on my laptop. Doing it on my PC would just be a bit handier, since I have two screens there.

That’s too bad, if there are no messages in any of those logs, it is difficult to determine the cause of the crash.
Maybe ELAN’s log contains information, but probably not (files named elan0.log, elan1.log etc. in ELAN’s data folder. In case of doubt you can send the file(s) to me (han.sloetjes AT mpi.nl).

The log file only has info on a launch of the program on November 19, 2021. So nothing about the current error I’m getting. I doubt there will be anything useful in that file, since apparently last time it was changed was on that same day. What a shame. I’ll just use ELAN on my laptop then. Thank you nevertheless! I appreciate that you replied so quickly. :smile:

I am having the same message but on a different context. For me, the crash happens when I am editing an annotation. I am using Windows 10 and a brand new ELAN installation. I used ELAN before, but this is my first project on this laptop.
This is the content of hs_err_pid14340.log, located on C:\Program Files\ELAN_6.3:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_STACK_OVERFLOW (0xc00000fd) at pc=0x00007ff96c892ec3, pid=14340, tid=2172
#
# JRE version: OpenJDK Runtime Environment (17.0.2+8) (build 17.0.2+8-86)
# Java VM: OpenJDK 64-Bit Server VM (17.0.2+8-86, mixed mode, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)
# Problematic frame:
# V  [jvm.dll+0x382ec3]
#
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
#
# If you would like to submit a bug report, please visit:
#   https://bugreport.java.com/bugreport/crash.jsp
#

---------------  S U M M A R Y ------------

Command Line: -Djpackage.app-version=6.3 -Djava.library.path=C:\Program Files\ELAN_6.3\app\nativelib -Xms512m -Xmx1024m -Djava.util.logging.config.file=C:\Program Files\ELAN_6.3\app\elanlog.properties -Delan.properties=C:\Program Files\ELAN_6.3\app\elan.properties -Dswing.aatext=true -Dsun.net.client.defaultConnectTimeout=-1 -Dapp.extensions.dir=C:\Program Files\ELAN_6.3\app\extensions --add-opens=java.base/java.lang=ALL-UNNAMED -Djpackage.app-path=C:\Program Files\ELAN_6.3\ELAN.exe mpi.eudico.client.annotator.ELAN

Host: AMD Ryzen 5 5500U with Radeon Graphics         , 12 cores, 5G,  Windows 10 , 64 bit Build 19041 (10.0.19041.1645)
Time: Thu May  5 13:49:59 2022 Hora Padrão da Turquia elapsed time: 5080.063560 seconds (0d 1h 24m 40s)

---------------  T H R E A D  ---------------

Current thread (0x000002408c30c020):  JavaThread "EventPoster" [_thread_in_vm, id=2172, stack(0x0000005f3dd00000,0x0000005f3de00000)]

Stack: [0x0000005f3dd00000,0x0000005f3de00000],  sp=0x0000005f3ddff9e0,  free space=1022k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
V  [jvm.dll+0x382ec3]
V  [jvm.dll+0x670ad2]
V  [jvm.dll+0x383b1b]
V  [jvm.dll+0x383da7]
V  [jvm.dll+0x409b21]
V  [jvm.dll+0x7859bb]
V  [jvm.dll+0x77ff7a]

Thanks for this message.
In the meantime we received several log reports, but so far haven’t found a clear problem or pattern linking them all. In some cases the problem seems to be related to allocation of memory, in other cases not.
You mention the crash (always?) occurs when creating a new or editing an existing annotation and that doesn’t seem to be related to a lack of memory. This brings up the thought the problem might be in the Java version (17.0.2) that is packaged with ELAN 6.3. ELAN 6.2 contains a lower Java version (14); you could maybe try that version too and verify whether or not the same problem exists there as well. If not, that would support the idea that the problem might be in the Java version.

-Han

Hi,
I recently purchased a laptop with a graphics card, but Elan does not function on it. Elan always freezes before crashing with the message “Child process exited with code xxxx,” where xxxx can stand for any number. It can be either 1 or 3221225477 at random. In actuality, every member of our team has the same laptop model, and we are all having the same issues.

My group and I were using Elan 6.3. I uninstalled it and installed version 6.2. I’ll work on it for a few days and then respond with my findings.

In the meantime, if anybody has any solutions, please revert

Hi, we still haven’t found the cause(s) of these problems; the crash messages often seem to point at memory management issues, but it’s still unclear why this occurs on PC’s with more than enough memory installed.

In your case, are you working with a video and wav file linked or only one of those two? And do you have the waveform and/or spectrogram visible on screen?
It would be useful to us if you could send us a few of the mentioned “hs_err_pid” log files, from different machines (han.sloetjes AT mpi.nl).

Hello

I too have the same issue (Windows 10 too). However, all the annotations on whichever video I am working on at the time the error occurs disappear. There seems to be no reason for the error to occur. the entire system seems to freeze, blackout and then ends, where I then receive the message. Any suggestions much appreciated!

Hello,

Unfortunately we still don’t have a definite understanding of the cause(s) of these crashes. We made some changes in ELAN 6.4 in areas where we think a possible cause for crashes might lie, but it seems the problem isn’t solved yet.
We are still interested in receiving the “hs_err_pid” log files as mentioned before.
A general recommendation is to switch off viewers that are not used or needed (via the View->Viewer menu), especially, when working with video files only, to switch off the Spectrogram and Signal viewer and see if that makes any difference. And to activate the automatic backup option to try to prevent loss of annotations as much as possible.

-Han