ELAN 6.3 and 6.4 extremely buggy on all M1 macs

Our lab recently purchased new mac M1 computers (some iMacs and some macbooks). We downloaded the most recent version of ELAN (6.4 for M1) and found extreme performance issues. We use ELAN to annotate 16-hr audio recordings of infant language environments. We worked through various previous releases and the one that works most similarly to our previous experience is 6.2-M1, so we’ve been preceding with this version. All computers run MacOS Monterey.

Some issues we noticed with 6.3- M1 and 6.4-M1:

  • Frequent freezing and crashing during playback in transcription mode: coder will try to pause the audio recording and neither the pause button nor the control+space keypress will pause it; the cursor willl disappear and ELAN freezes
  • Inability to select an annotation in the viewer using double click: instead of selecting the annotation, jumping the cursor and timeline to that annotation, and opening the editor, a double click instead just skips over the annotation to a nearby annotation
  • Selecting a segment in Grid mode doesn’t snap the cursor or timeline viewer to that segment
  • Lag loading the viewer during playback in transcription mode-- the timeline skips and has pain gray boxes covering tiers and annotations as if it’s still loading
  • issues switching from transcription mode to segmentation mode etc., sometimes needing to switch between 3+ modes before the view changes to the right mode
  • Failure to select an annotation value using keyboard shortcuts for a controlled vocabulary: when we have the “modify annotation value” dialogue open on an annotation that uses a controlled vocab, pressed the letter for the designated value doesn’t fill that value in on the annotation
  • given the difficulty of selecting the right annotations or stretches of time, keyboard shortcuts that reference the cursor or the current selection often do not work

The problem is not insurmountable since version 6.2 works for our purposes, but I thought it may be helpful if these issues were documented somewhere!


Dear Lilli,

Thank you for your detailed report, disappointing as the message is. I assume the descriptions should allow us to try to reproduce the issues. For most of the seven points the “mode” is already explicitly mentioned, but for some points this could maybe still be added (point 3, Grid mode, is that the Grid viewer in Annotation mode?, in which mode is point 6?)? And do none of these issues occur in ELAN 6.2?

I’m trying to think of whatever could cause these differences in behavior. ELAN 6.3 and 6.4 include a newer version of Java and the new Spectrogram viewer has been introduced (which can be switched off). Apart from that a few other new functions and changes have been made, none of which I can immediately link to the problems you describe. But we will try to reproduce the problems and discover their cause(s).


Hi Han,

Yes, I meant to refer to the grid viewer in annotation mode in point 3. Point 6 is also in annotation mode-- that’s the main mode we work in, so unless otherwise mentioned I probably mean annotation mode! I also would like to amend 1, 4 and 5 to say annotation mode and not transcription mode-- sorry about that!

One more problem I’ve encountered since writing my post is that the crosshair and selection in annotation mode sometimes get “stuck” on a certain point, and even if I try to move the crosshair, or click and drag, or edit an annotation at a different time point, that point is the only one I can e.g. start playback from.

Intuitively it feels like it may be some interaction between Java and the sensitivity of magic mice/trackpad and other commands: it seems like some of the issues (e.g. with laggy playback) happen because ELAN is trying to zoom in and out during playback as if we had pressed ctrl+side scrolled instead of ctrl+space; same with skipping annotations when we try to double click or failing to open the dialogue long enough to choose an option when right clicking an annotation. I’m not sure if this is a well based intuition or not!

Thanks for all your help (and for creating ELAN in general!)

And no, we don’t have any of the same errors in 6.2.

Thanks for the clarifications concerning the mode, Lilli, that’s useful.
The same for your remarks concerning the magic mouse/trackpad. This is maybe something you could test; work a while on one of the M1’s with an ordinary mouse and see if that makes a difference. I’m not sure if we have a magic trackpad around here, but I guess we can try the interaction with a magic mouse at our end too.
If the divide between working and not working versions was between 6.3 and 6.4 I would suspect the problems might be related to the introduction of the scrollpane in which the timeline viewer is now embedded (replacing the separate scrollbars we used to maintain). But if the problems don’t occur in 6.3 that doesn’t really make sense.

You mentioned 16-hr audio and I didn’t ask yet whether the recording is cut up into smaller segments for the purpose of annotation. We are sometimes asked whether the duration of recordings and/or the size of media files do matter and we don’t really know that well. Is this maybe something you could try; whether the problems are related to the length of the recording being annotated?


Thanks a lot for ELAN and also this forum.
I also experienced this problem. With @hasloe comments, I tried unchecking the signal view and spectrogram view in version 6.4, and it worked smoothly.

Turning the two on, one by one, revealed that the problem is mostly with the spectrogram view. The signal viewer makes scrolling and scaling the timeline a little choppy but not by much.

So, I think I will have the spectrogram off for a while.

Thanks again,

Thanks Yahya, it’s good to get such feedback.

As of ELAN 6.1 the signal viewer can be shown based on a video alone, so without an additional .wav file being linked. But if performance is an issue and the signal- and or spectrogram viewer are essential, it is best to also link a .wav file, extracted from the video. When the audio samples can be loaded from a .wav file, this will have less impact on the performance.


Hello - I’m a fairly new ELAN user, and also running into what I think are issues that might be specific to M1 Macs, but I haven’t compared this against other versions of hardware or software. I’m running ELAN 6.4-M1 on Monterey (12.3.1). Issues that I’ve encountered so far include:

  • No timeline zoom control in annotation mode (workaround: it’s possible to use the one that appears in segmentation mode
  • Similar issues with controlled vocabulary: searching by typing works intermittently
  • Lexicon services: I’ve linked a sign language lexicon, but the associated videos only display intermittently, and when they do, I can only see part of the video (as if it’s zoomed in to the lower left corner)
  • Media viewer: sometimes the media file that’s loaded appears squished in the upper left corner of the viewer (workaround: closing and re-opening the viewer has been successful)
  • Tier types: this might be my inexperience talking, but I’m having difficulty combining a tier that uses a controlled vocabulary with a dependent tier that does NOT use a controlled vocabulary. The manuals that I’m following lead me to believe that this is possible, but when I remove the controlled vocabulary from the dependent tier, it also removes it from the parent tier. Is that a bug or a feature?
    *UPDATE: It looks like the controlled vocabulary issue persists even when tiers are NOT dependent. In other words, I am only able to have a single controlled vocabulary for ALL tiers (or to have no controlled vocabulary for any tiers). This is definitely a problem: the question is whether it’s a tech bug or user error!

I may continue to log issues here, unless it would be more appropriate to create a separate thread? Much appreciated! -Matt

Hello Matt,

Thanks, that are quite a few issues. I’ll respond to a few here, some, especially the ones that occur intermittently, might need more detail or maybe example files. We can see if it makes sense to create separate threads for those.
Concerning the listed issues:

  1. This issue has been discussed here, I think.
  2. I will try to reproduce that, but more details might be required to understand why it only sometimes doesn’t work
  3. I believe that sizing issue should be fixed in the next release, not sure if not showing up sometimes is related to that
  4. That issue seems one of the issues discussed in this post. If I’m correct resizing the video area with the divider below the row of media player buttons forces the video to scale correctly.
  5. It is definitely possible to have different vocabularies for different tiers and to have tiers with and tiers without vocabularies. This problem can maybe best be further explained by sending an example file by email?


My lab is experiencing the same issues as @lrighter while working with 720p video files, 5-60 minutes in length. No apparent relationship between video length/size/encoding standards and these issues.

I have three RAs who are working with the files on their own computers. Two have M1 Macs, one has a 2019 Mac. I am also working with a 2021 M1 Mac. We have exactly the same issues with freezing and crashing, inability to select annotations, lag loading the viewer, and using our controlled vocabulary. These are better for the student who’s not on the M1 Mac but they’re a problem for everybody, including her.

Besides what Lilli mentioned, we’re also experiencing these issues in segmentation mode and annotation mode:

  • Video playback is choppy or lags
  • ELAN becomes unresponsive and users have to force quit. This is resulting in users losing all of their work even if they have manually saved several times - I assume the autosave function is overwriting what they manually saved
  • Audio is in a separate file from video. When hitting play in segmentation mode, audio doesn’t play from the timepoint where the cursor actually is, instead plays from another timepoint (nowhere nearby)
  • Audio plays, but cursor doesn’t move, when hitting play in segmentation mode

I’m having my students downgrade to ELAN 6.2 to see if we can resolve these issues.

Thank you for this additional information, any piece of information we can get, can help to identify the (main) cause of the problem. It’s still not clear to me what the problem is, so crash reports (like the ‘Send to Apple’ reports) an elan log files would still be welcome (han.sloetjes AT mpi.nl).

What can be ruled out, at least for the problems in your lab, is that the main problem is in the Spectrogram viewer (not visible in Segmentation Mode) or in the extraction of audio samples from video (a separate wav file is linked). These are two of the main differences between 6.1/6.2 and 6.3/6.4. Another difference is the included Java version, I don’t immediately see how that could lead to choppy video playback, but we cannot rule that out as possible cause of the issues.

The actual video encoding could otherwise also be a cause of problems, but if the videos run smoothly in 6.1 or 6.2, I think we can rule that out too. It would still be useful if someone could confirm that the same problem occurs in 6.3/6.4 with e.g. the ACLEW examples from our resources page.

Concerning the automatic backup function: this creates separate files, named e.g. abc.eaf.001 (etc.) for a file abc.eaf. In order to see what has been saved in the last backup, the suffix has to be removed so that the file can be opened in ELAN.