Cannot open ELAN.exe with double clicking

Hi, I just downloaded ELAN5.9 and installed it without any problem. But I can’t open it with double clicking the desktop shortcut or elan.exe. By double clicking it, there was just no response, I cannot see the programme in the task manager. I have JAVA environment JDK14.0.1 and my OS is windows 10. Can anyone help? Thank you very much!

Hi, if nothing happens when you double-click the ELAN.exe, I assume you don’t have a “.elan_data” folder in your home directory, containing a file elan0.log? That could be a source of information, otherwise there might be messages in the system logs (Event Viewer)?
You could also right-click the .exe and select Properties and e.g. troubleshoot compatibility or run the .exe as administrator?
By the way, ELAN is installed with its own Java environment (so it won’t use the pre-installed JDK14.

Thank you for the help! I tried troubleshoot compatibility and also ran the .exe as administrator, but there was still nothing happended.
Also thanks for letting me know the ELAN’s own JAVA environment!

Hmm… Maybe you can run the ELAN.exe from the command line and see if that generates error messages? Otherwise you can try to launch ELAN and then go to the Event Viewer and see if in any of the Windows Logs there are error messages that can be linked to the the launching of ELAN?

Thank you for your reply!

I run ELAN.exe from command line but there was still nothing happened. I found an error messages from my application logs in the Event Viewer:
svchost (10064,R,98) TILEREPOSITORYS-1-5-18: Error -1023 (0xfffffc01) occurred while opening logfile C:\WINDOWS\system32\config\systemprofile\AppData\Local\TileDataLayer\Database\EDB.log
But I don’t think it is related to my ELAN proplem, as after I creat the two directories [TileDataLayer] and [Database] under the path C:\WINDOWS\system32\config\systemprofile\AppData\Local\TileDataLayer\Database, it did not happen again…

I attached a screeshot, I am not sure it can help… Thank you again for your patience.
image

Thanks, that error indeed doesn’t seem to be related.
Just to be sure, since you didn’t explicitly confirm that: you don’t have a “.elan_data” folder in your user’s home directory (usually something C:\Users\your_name)?

No, I don’t have the “.elan_data” folder in my user’s home directory.

Ok, if there are no logs generated by ELAN, no console output when running from the command line ánd no error messages in the Event Viewer, then it is almost impossible to determine what is going on.
You could open the Task Manager, then launch ELAN to see if it (under the name “OpenJDK Platform binary”) at least for a moment appears in the list of processes.
Finally you could try to run the java command that launches ELAN from the command line, but this all maybe goes a bit too far.

Hi, thank you again for your kind help… actually I never saw ELAN appeared in the Task Manager after I launched it … But I tried ELAN 5.7 (32-bit windows version), and it worked… I think I will just work with ELAN 5.7 then

Ok, if that one works, then that’s fine.
Just out of curiosity, your Windows 10 version is 64-bit? Or 32-bit?

It is 64-bit version