Annotation unit order and associations messed up during "merge annotation"

We get instances of annotation unit order and associations messed up during “merge annotation” - both regarding the “first source” annotations (as in the screenshots) and in the “second source” annotations. Thanks for any hints on how to prevent this.

It looks like the order is already wrong on the first subdivision tier, the word-txt tier. In earlier, similar reports we received, the misalignment usually started on a lower level. I thought these issues/bugs were mostly solved, but apparently not (assuming this is in a fairly recent version of ELAN). Is it possible to send e.g. the two files of the screenshots to me so that we can test with those files? Since files with a similar structure that I have seem to merge well, it might be that errors only occur in very specific situations.

If there are (still) bugs in the Merge Transcriptions function, there is not much one can do to prevent this. The only thing that can be tried, for an occasional set of files, or just for testing purposes, is to:

  • in a first pass only select the top-level tiers, up to and including the word-txt tier, of the two sources
  • if the annotations on the word-txt tier are copied in the correct order (which would already be interesting to know), an attempt can be made to merge the morph tiers of the first source with the merged file
  • if that works, the morph tiers of the second source could be merged as well (with the latest merged file)

Obviously this is not a viable approach if many sets of transcriptions need to be merged, but this procedure can provide insights on where things go wrong. (I can perform this procedure in case it is possible to send those .eaf files to me).